Got networking / internet / computer/ TV/ Telephone problems in Crete? Ask here.
Posts: 96
Joined: Sun Dec 06, 2009 11:06 am
Location: Drapanos

Postby Dinksy » Mon Jul 04, 2016 4:30 pm

We are experiencing problems when trying to watch TV on Filmon. We keep getting adverts that cut the channel we are watching and we have to return to the home page to restart watching the channel and this triggers even more ads. The help desk from Filmon have said it is a new policy of theirs to run more ads but this lack of returning to the channel we were on and showing a blank TV screen is a major problem. Yes I know we could watch it in HD but using satellite as supplier does restrict our band width availability. Yes, we have cleared are browser but this does nothing.

Any thought please.
Never mind the quality, feel the width.

Posts: 370
Joined: Mon Aug 13, 2012 8:26 am
Location: North East Crete or S.W.England


Postby Mixos » Tue Jul 05, 2016 12:12 pm

When did this start happening Dinksy? In the last month or so as I haven't been using it since the end of May? I have had something similar in the past -- I would select, say BBC2, click full screen to start watching then after about 30 seconds it would jump back to some random US channel. I assumed it was something to do with my laptop, so I tried watching in small screen mode for about three or four minutes BEFORE clicking full screen and the problem stopped! Try that?

Posts: 12
Joined: Sat Jun 11, 2016 7:06 pm
Location: neo chorio


Postby starfish » Tue Jul 05, 2016 2:42 pm

We watch filmon through an android tv box and apart from buffering sometimes we have no problems

Posts: 96
Joined: Sun Dec 06, 2009 11:06 am
Location: Drapanos


Postby Dinksy » Tue Jul 05, 2016 4:42 pm

In reply to the question, when did it start? It was about the same time as the Euro footy started so quite recently.

Ads are appearing about every 12/15 minute intervals. Could accept them if it did no knock out the channel being watched.
Never mind the quality, feel the width.

Posts: 722
Joined: Mon Jul 02, 2007 9:56 am
Location: Chania


Postby allan » Tue Jul 05, 2016 5:35 pm

I have been using Film On for a few years now and have never experienced the problem you are having.
I always chose SD for every channel, even my tablet has no adverts.

Only thing that has happened recently is the loss of the Dave channel.

Hope you manage to sort the problem.

Posts: 141
Joined: Wed Jun 15, 2011 8:41 pm
Location: Jersey/ Neapoli Crete


Postby louisejersey » Wed Jul 06, 2016 9:20 pm

Dinksy, exactly the same thing happening to me, and the same time frame. I have no objection to the adverts, just the fact that I get a blank screen afterwards. No solution I'm afraid, but you are not alone in this. x

Return to “ Computers, TV, Telephone and Internet”

Who is online

Users browsing this forum: No registered users and 1 guest